Tipo Ruby: Malsamoj inter versioj